2018 Q4 Platform Update: GenFlow, Maven Central, Java 11 and Eclipse

Happy Holidays!  :-)
With a flurry of new releases, we are opening up our code generation framework to the API community, and now publishing to Maven Central for easier access from secure environments. We've also brought RepreZen API Studio up to date with new Java and Eclipse releases. 
Here are the high points:
  • GenFlow: An Open Framework for API Code Generation
    RepreZen's best-in-class code generation capabilities are repackaged as GenFlow, soon to be announced as an open source project on GitHub. This is great news for developers who want to customize the built-in GenTemplates! We recommend updating your projects to the new format, as described below.
  • Code Generation Available on Maven Central
    The GenFlow framework, GenTemplates, and their dependencies are now hosted entirely on Maven Central, so GenFlow enabled projects no longer need access to RepreZen's Maven repository at maven.reprezen.com.
  • API Studio Desktop Installs and Runs on Java 11  
    RepreZen API Studio release 1.6.15 addresses a Java 11 compatibility issue with its Eclipse Oxygen target platform. The fix is implemented in the API Studio Desktop installer, which now pre-configures API Studio to run with a compatible Java installation. See below for important details.
  • API Studio for Eclipse Now Works with Eclipse 2018-09 IDEs
    Also in API Studio release 1.6.15, we've made some minor updates for compatibility with Eclipse 2018-09. We also expect full compatibility with the upcoming Eclipse 2018-12 release scheduled for GA on December 19th. 

How do I get the new API Studio release?

If you're running API Studio Desktop, you'll see a notification of available upgrades when you first launch API Studio.
If you're running API Studio for Eclipse, depending on your Automatic Update preference settings, you may see an update notification.
You can use Help > Check for Updates to check for a new release, regardless of which API Studio installation you're running.
Learn More: 
RepreZen API Studio Installation Options: Desktop and Eclipse IDE external link icon 
How can I update to the latest release of RepreZen API Studio? external link icon 

Will my existing RepreZen projects work with GenFlow?

Your existing pre-GenFlow projects, created with RepreZen API Studio 1.6.12 and earlier, will run in the newer API Studio release without any modification.
Likewise, new GenFlow-enabled projects that you create in API Studio 1.6.13 and later work without modification in API Studio 1.6.12 and earlier releases.
However, you cannot create or execute a new GenFlow GenTarget in a pre-GenFlow project.
We recommend updating your existing projects to work with GenFlow. Project update is safe, automated, and ensures that you have access to the latest GenTemplates and code generation technology. See the related topic for details.

Do I need to reconfigure my Maven settings for GenFlow?

If you have existing projects that have not yet been converted to GenFlow format, you'll still need access to the RepreZen Maven repository in the maven.reprezen.com domain. Once your projects are in GenFlow format, you should no longer need access to this domain. 
You will need access to Maven Central artifacts. Most secure environments will already provide access to the artifacts published on Maven Central through one or both of the following options: 
  • Direct access to Maven Central
    Your firewall may already whitelist the repo.maven.apache.org domain. In that case, as long as your Maven proxy is configured correctly, GenFlow should work correctly in RepreZen API Studio, without any new configuration changes.
  • Internal Mirror of Maven Central
    Some environments mirror Maven Central (and sometimes other Maven repositories) to an internal Maven server, behind the firewall. You can configure Maven to resolve dependencies using use the internal mirror, so you don't need direct access to Maven Central on the internet.

What do I need to know about Java 11 compatibility?

You'll need to reinstall or reconfigure API Studio Desktop for Java 11 compatibility.

The Java 11 compatibility fix is in the API Studio Desktop installer, so updating from inside API Studio Desktop or Eclipse will not apply the fix.
Starting with release 1.6.15, the API Studio Desktop installer detects your Java installations and pre-configures the API Studio Launcher to run with the best available Java version. It will only choose Java 11 if it does not find Java 8, 9, or 10. If the installer chooses Java 11, it will make an additional OSGi configuration change for Java 11 compatibility. 
You can manually reconfigure API Studio to run with your Java installation as described here

Eclipse Photon and later releases are already compatible with Java 11.

If you're running API Studio for Eclipse, API Studio won't touch your Eclipse launcher and OSGi configurations. Eclipse Photon and later releases run on Java 11 without requiring any special configuration. You can install RepreZen API Studio from the Eclipse Marketplace, and it will run normally.

Develop Custom GenTemplates on API Studio Desktop with Java 8, 9, or 10.

Using the GenFlow framework, RepreZen API Studio allows you to build custom code generators, called GenTemplates. API Studio includes a complete environment with project templates and wizards for development of custom GenTemplates. 
However, these features are tested and fully supported only in API Studio Desktop running on Java 8, 9, or 10. They will not work with Java 11, and also may not work with API Studio for Eclipse, installed from the Eclipse Marketplace into a standard Eclipse IDE distribution.
Learn More: 
What Java Releases are Compatible with RepreZen API Studio? external link icon 
How do I run API Studio with a specific Java version? external link icon 
Solution: Java Requirement Error Messages external link icon 
RepreZen API Studio: Java and Eclipse Compatibility Matrix external link icon 

Will API Studio run in the new Eclipse 2018-12 release? 

Eclipse 2018-12 will be released for general availability on December 19th. The current 1.6.15 release of API Studio runs without any known issues on the RC1 release candidate of Eclipse 2018-12. We are completing our testing now, and expect that API Studio will be fully compatible with the final release of Eclipse 2018-12.

Login or Signup to post a comment